69 RR efi conversion - would you consider this efi fuel pump excessively loud.

Fuel and Air Systems

  1. skingjack

    skingjack Active Member

    Messages:
    44
    Likes Received:
    8
    Joined:
    Jul 14, 2015
    Location:
    YEG
    Local Time:
    2:32 PM
    Hi, did a complete tanks inc kit efi replacement gas tank/pump kit but in my opinion, the fuel pump is excessively load ( too loud for my liking). Having observed other conversions on other vehicles, it seems to be excessively loud... those conversions are much quieter with same components. Your thoughts and feedback welcomed as to whether you think This is out of the ordinary.



    Ian
     
  2. skingjack

    skingjack Active Member

    Messages:
    44
    Likes Received:
    8
    Joined:
    Jul 14, 2015
    Location:
    YEG
    Local Time:
    2:32 PM
    Here is the link

     
  3. skingjack

    skingjack Active Member

    Messages:
    44
    Likes Received:
    8
    Joined:
    Jul 14, 2015
    Location:
    YEG
    Local Time:
    2:32 PM
    Technical difficulties... apparently I cannot add the link or need to figure how to do it
     
  4. skingjack

    skingjack Active Member

    Messages:
    44
    Likes Received:
    8
    Joined:
    Jul 14, 2015
    Location:
    YEG
    Local Time:
    2:32 PM


    Try this
     
  5. chtampa

    chtampa FBBO Gold Member FBBO Gold Member

    Messages:
    2,444
    Likes Received:
    3097
    Joined:
    Nov 24, 2013
    Location:
    Tampa, FL
    Local Time:
    4:32 PM
    My 69 Convertible EFI pump is loud. In tank unit with flex lines and I have accepted it.
     
  6. skingjack

    skingjack Active Member

    Messages:
    44
    Likes Received:
    8
    Joined:
    Jul 14, 2015
    Location:
    YEG
    Local Time:
    2:32 PM
     
  7. skingjack

    skingjack Active Member

    Messages:
    44
    Likes Received:
    8
    Joined:
    Jul 14, 2015
    Location:
    YEG
    Local Time:
    2:32 PM
    Resolved the link posting issue...so does anyone others efi fuel pump sound like this?
     
  8. boss302dave

    boss302dave Active Member

    Messages:
    30
    Likes Received:
    29
    Joined:
    Sep 14, 2015
    Location:
    Dearborn Michigan
    Local Time:
    3:32 PM
    I have a Holley Sniper EFI in my 69, with the in-tank pump from Holley and it sounds NOTHING like that. :wtf: I can hear mine, but it's not objectionable. No way could I live with that! Good luck
     
  9. furious70

    furious70 Well-Known Member

    Messages:
    618
    Likes Received:
    286
    Joined:
    Jun 30, 2020
    Location:
    Chicagoland
    Local Time:
    3:32 PM
    That's inside the tank? Full of fuel?
    I have run a walbro 255 hanging on the frame rail of my efi fury since 2009 and on an all day drive it'll talk to me... But not that loud. Sounds like it's working really hard. Was it that loud from the start?
     
  10. 6872n73

    6872n73 Well-Known Member

    Messages:
    182
    Likes Received:
    129
    Joined:
    Apr 5, 2010
    Location:
    Oklahoma
    Local Time:
    3:32 PM
    Sounds loud.
    Could check for areiation of the pump inlet?
     
  11. skingjack

    skingjack Active Member

    Messages:
    44
    Likes Received:
    8
    Joined:
    Jul 14, 2015
    Location:
    YEG
    Local Time:
    2:32 PM
    Unfortunately, always that loud since the installation. Pump inside the tank.
     
  12. Dennis H

    Dennis H FBBO Gold Member FBBO Gold Member

    Messages:
    15,246
    Likes Received:
    19479
    Joined:
    Jul 11, 2010
    Location:
    San Jose
    Local Time:
    3:32 PM
    Can’t hear mine. Think it’s an over the counter AC Delco like used in Vettes.

    Link did not open.
     
  13. 451Mopar

    451Mopar Well-Known Member

    Messages:
    2,642
    Likes Received:
    1952
    Joined:
    Oct 25, 2011
    Location:
    Aurora, CO
    Local Time:
    2:32 PM
    sounds loud for an in-tank pump. what pump? I would think it might be cavitating, or have some other problem?
     
    • Agree Agree x 1
    • threewood

      threewood FBBO Gold Member FBBO Gold Member

      Messages:
      5,029
      Likes Received:
      6570
      Joined:
      May 30, 2014
      Location:
      Yuma, AZ
      Local Time:
      1:32 PM
      That sounds loud to me as well.

      I'm running a Holley EFI tank with a Walbro 455lph pump and it is pretty quiet. I can't hear it when the car is running.
       
    • 70chall440

      70chall440 Well-Known Member

      Messages:
      2,959
      Likes Received:
      4316
      Joined:
      Feb 11, 2018
      Location:
      Yelm, Washington
      Local Time:
      1:32 PM
      I have an in tank TANKs pump and an Walbro frame mounted pump (2 different vehicles) and neither sounds anything like that. My guess is that that pump is defective.
       
    • skingjack

      skingjack Active Member

      Messages:
      44
      Likes Received:
      8
      Joined:
      Jul 14, 2015
      Location:
      YEG
      Local Time:
      2:32 PM
      And our findings when the tank dropped & pump pulled

      08683903-F54E-4167-AC85-42C8A157646B.jpeg
       
    • 451Mopar

      451Mopar Well-Known Member

      Messages:
      2,642
      Likes Received:
      1952
      Joined:
      Oct 25, 2011
      Location:
      Aurora, CO
      Local Time:
      2:32 PM
      Is the filter plugged already?
       
    • watermelon

      watermelon Well-Known Member

      Messages:
      1,289
      Likes Received:
      1318
      Joined:
      Sep 7, 2010
      Location:
      main street, usa
      Local Time:
      1:32 PM
      that prefilter will look dark once it gets wet...looks normal to me

      if it’s loud enough to hear over a mopar engine and exhaust swap it...especially since you have it out


      watermelon
       
    • 451Mopar

      451Mopar Well-Known Member

      Messages:
      2,642
      Likes Received:
      1952
      Joined:
      Oct 25, 2011
      Location:
      Aurora, CO
      Local Time:
      2:32 PM
      My pre-filter does not look black? Just a thought?
      Test by placing pump in fuel jug (I use a 5-gallon Fuel jug) without the pre-filter and see if it pumps fuel (into another fuel jug or gas tank) and still makes the noise.
      Then test with the pre-filter on?
       
      • Agree Agree x 1
      • skingjack

        skingjack Active Member

        Messages:
        44
        Likes Received:
        8
        Joined:
        Jul 14, 2015
        Location:
        YEG
        Local Time:
        2:32 PM
        Problem resolved... clean tank, new pump and filter. Good to go... the 493" so far is liking the extra fuel rather than being starved for it. Now if mother nature would cooperate I could really test her out.

        Ian
         
        • Like Like x 4
        1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
          By continuing to use this site, you are consenting to our use of cookies.