Front passenger turn signal

Gerrs69rr

Well-Known Member
Local time
6:54 PM
Joined
Nov 7, 2015
Messages
93
Reaction score
129
Location
VA Beach VA
Ok this one has got me! 4way flashers work on all four corners, both indicators on dash work fine, left turn signal works fine back and front, indicator on dash works, right turn signal works on the back but the front light and indicator on dash is not working?????? Any ideas
 

davek

FBBO Gold Member
FBBO Gold Member
Local time
7:54 PM
Joined
Oct 14, 2017
Messages
6,784
Reaction score
6,756
Location
columbia SC
have you tried to ground front light to see if its a bad ground?
 

Gerrs69rr

Well-Known Member
Local time
6:54 PM
Joined
Nov 7, 2015
Messages
93
Reaction score
129
Location
VA Beach VA
I did not, I assumed 4 ways worked so I was Good, lol.....I assumed on electrical discrepancy, I'll give it a shot
 

chtampa

FBBO Gold Member
FBBO Gold Member
Local time
7:54 PM
Joined
Nov 24, 2013
Messages
3,607
Reaction score
4,432
Location
Tampa, FL
Is the turn signal switch a reproduction?
 

bcOH67

FBBO Gold Member
FBBO Gold Member
Local time
7:54 PM
Joined
Jul 25, 2019
Messages
105
Reaction score
27
Location
Youngstown, OH
Did you run a temp ground and connect it right to the light housing and try it? I literally just fixed the same exact problem two days ago. The screws that held the light bulb housing in weren’t transferring a good ground. Cleaned them up and fixed it in two seconds.
 

Gerrs69rr

Well-Known Member
Local time
6:54 PM
Joined
Nov 7, 2015
Messages
93
Reaction score
129
Location
VA Beach VA
Did you run a temp ground and connect it right to the light housing and try it? I literally just fixed the same exact problem two days ago. The screws that held the light bulb housing in weren’t transferring a good ground. Cleaned them up and fixed it in two seconds.
No I just did the grounds on core support, I'll give that a shot tomorrow
 

bcOH67

FBBO Gold Member
FBBO Gold Member
Local time
7:54 PM
Joined
Jul 25, 2019
Messages
105
Reaction score
27
Location
Youngstown, OH
On mine, that same bulb/housing didn’t come on with my running lights either. Found out that the only thing those two functions in that particular location share is a ground. So I’m hoping that’s your issue to so you have an easy fix
 

Gerrs69rr

Well-Known Member
Local time
6:54 PM
Joined
Nov 7, 2015
Messages
93
Reaction score
129
Location
VA Beach VA
I got back on it this morning, removed housing and cleaned everything up, went through bulkhead connector to ensure all pins are set. Still the same, parking light works fine, flashes with four way but will not flash (verified no power at bulb) with turn signal. You can hear flasher clicking and rear tail light is blinking.
 

1967coronet

Well-Known Member
Local time
6:54 PM
Joined
Jun 19, 2014
Messages
4,251
Reaction score
5,838
Location
Iowa
Yes it is, 8 years ago or so
Just had the same problem.
My old original turn switch would not cancel on right turns.
I pulled the wheel and used a replacement switch.
The one I used was the top half switch with the red and white leads you splice in.
Tested lights before replacing the wheel and found exact problem you described.
It was the spring wire contacts on the bottom side ,one of the stainless wires was setting to low or flush with the plastic.
It would not touch the brass contact when leveled to position.
Bent it up slightly and the front turn and dash indicator returned.
Hope that is all yours needs.
 

Gerrs69rr

Well-Known Member
Local time
6:54 PM
Joined
Nov 7, 2015
Messages
93
Reaction score
129
Location
VA Beach VA
Just had the same problem.
My old original turn switch would not cancel on right turns.
I pulled the wheel and used a replacement switch.
The one I used was the top half switch with the red and white leads you splice in.
Tested lights before replacing the wheel and found exact problem you described.
It was the spring wire contacts on the bottom side ,one of the stainless wires was setting to low or flush with the plastic.
It would not touch the brass contact when leveled to position.
Bent it up slightly and the front turn and dash indicator returned.
Hope that is all yours needs.
I'm yanking the wheel tonight, I'll let you know how it goes. This is my last discrepancy I need to fix before I make this 6 hour trip to Carlisle in a few weeks
 

Gerrs69rr

Well-Known Member
Local time
6:54 PM
Joined
Nov 7, 2015
Messages
93
Reaction score
129
Location
VA Beach VA
Just had the same problem.
My old original turn switch would not cancel on right turns.
I pulled the wheel and used a replacement switch.
The one I used was the top half switch with the red and white leads you splice in.
Tested lights before replacing the wheel and found exact problem you described.
It was the spring wire contacts on the bottom side ,one of the stainless wires was setting to low or flush with the plastic.
It would not touch the brass contact when leveled to position.
Bent it up slightly and the front turn and dash indicator returned.
Hope that is all yours needs.
Holy crap that was it! Easy fix, thanks to everyone for your inputs, I'm ready to hit the road.
 
Local time
7:54 PM
Joined
Apr 26, 2022
Messages
24
Reaction score
8
Location
Gastonia nc
Holy crap that was it! Easy fix, thanks to everyone for your inputs, I'm ready to hit the road.
I have same trouble as y’all , I’ve pulled the wheel , do I unplug , and remove turn switch?

FC7B521E-B584-44AF-B4DA-5483E3A22330.jpeg
 

Gerrs69rr

Well-Known Member
Local time
6:54 PM
Joined
Nov 7, 2015
Messages
93
Reaction score
129
Location
VA Beach VA
You shouldn't have to remove entire switch, mine had just enough slack in wire harness to pull it out just far enough to adjust small brass tabs, wouldn't hurt to clean them up and re grease with dielectric grease.
 

Top