• When you click on links to various merchants on this site and make a purchase, this can result in this site earning a commission. Affiliate programs and affiliations include, but are not limited to, the eBay Partner Network.

440 not pumping fuel after new fuel pump installed


Well-Known Member
Local time
7:28 PM
Oct 28, 2021
Reaction score
Central Illinois
Car stopped running on me. Poured a bit of gas down the carb and vroom! she started right up. OK, new fuel pump installed, still not pumping gas. Fuel bowls are empty on carb. Took out the fuel pump rod and it measures 3 1/16 with a tape measure. Don't have my calipers, so this could vary a bit. In my searching I see it's supposed to be 3 1/4 long approximately. Is 3/16 too short enough to cause this problem? Pushrod is not mushroomed on either end and it came out easily.
Might be on the edge of acceptable. When I first got my 66 Charger 383, my car was quite erratic and un reliable on fuel delivery. Push rod was worn to 2 15/16", barely stroking the pump lever. I believe it was the original push rod and had 78K miles on it at time of replacement. Replacing with new pushrod solved my issues. Have a new spare one, measures just a tiny bit under 3 1/4. I believe that new rod spec is 3.23" .
I just measured one I had lying around and it measured 3.226"
Need to get a pressure gauge on that fuel line. 6-7 Psi would be nifty. Lost of little things could cause a vacuum on fuel holding it back......but they usually add up due to heat or tank ventilation. You could disconnect line near the carb.....also the dizzy, and have a buddy get a few cranks going to see if it squirts.....pointing the line into a cup.
Are you sure you didn't "miss" the pushrod and it's wedged alongside of the pump arm when you installed it?
Did you check the rubber hose(s) at the gas tank and fuel pump to make sure you don't have one cracked and the pumps sucking air instead of gasoline?
All these guys are making great points. It's a matter of elimination.
1. Plenty of gas in tank?
2. No gas at carb (no "squirt" from accelerator pump when you move the throttle I assume)
3. You replaced the fuel pump and your fuel pump rod might be a little worn. I would think you would still get at least "some" gas up to the carburetor.

a. crack open the fuel line up near the carb (? - somewhere), crank the motor over and see if gas starts spraying out of where you cracked open the fuel line.
b. if NO fuel in fuel line --> install new fuel pump rod + another new pump (what the heck?) This might be a good time to make SURE you have fuel coming up to the fuel pump and not a fuel line leak (as mentioned) so your pump is sucking air. I'm not sure of good test (?) Maybe crack open the fuel line coming from the tank as it goes into the pump and see if gas pours out? Maybe hook up a rubber hose onto that fuel line coming from the tank and suck on it to see if it seems like you're sucking liquid or just air? Maybe somebody else here has a good trick for this
c. If fuel in fuel line --> you have a stuck "needle and seat" in your carburetor and/or a stuck (up) float inside the carburetor

d. oh yeah, if there's a fuel filter in between the fuel pump and the carburetor, then it "could" be horribly plugged up... I'd just change it regardless and not give it a second thought (if you have one)
I had same issue with 2 Chevy 350 Fuel pumps on a 78 Silver Anniversary Corvette
2 Push rods from NAPA were incorrect
actually, I damaged original Push Rod due to 2 incorrect length "arms" on two new fuel
As Purplebeeper mentioned
BUT, I NEVER thought 2 Fuel Pumps specifically ordered from the Store could be incorrect
But, wrong length could be the smoking gun....
When my pushrod failed it measured just barely over 3" the same as yours . This was in a 440 running carter pump
Worn eccentric on cam? Stick put your finger up against the rod & have somebody crank the engine to check movement.
Thanks for all the help! It ended up being the pushrod. Only about an eighth of an inch short, but wouldn’t pump any fuel at all. Picture shows difference between old & new.

Thanks for replying with the solution. So may threads start with a ask for help but never say what the fix was.
The amount of travel the fuel pumps lever requires is a lot less than you would think..
Well, my problem continues. New fuel pump, new FP pushrod so far. Drove it 50 miles to a car show saturday, made it all the way there. Had to wait in line to park at the show, so idling for a few minutes. Car dies, not getting fuel. Later that afternoon (4+ hrs ) I try to start it again, no go. Finally had someone choke it with their hand and now it fills up the carb bowl and it starts. Made it halfway home and stop for fuel...shut it off and it wont start again. Had to trailer it home.
I am beginning to think it is one of my first suspicions, Vapor Lock. Car runs fine while driving, as soon as I slow down heat is building up in the engine bay and fuel evaporates. Does that sound possible?
I am beginning to think it is one of my first suspicions, Vapor Lock. Car runs fine while driving, as soon as I slow down heat is building up in the engine bay and fuel evaporates. Does that sound possible?

How does it behave when the motors cold/first start? That would help answer the question!
I bet your filter in the tank, on the end of the pickup is probably clogged. That was my first suspicion when I read your post. Or you have a hose that is cracked.
Last edited:
It starts & runs great.
Then you have a heat soak/vapor lock condition! Next time it happens, treat the car as if it's flooded and start it that way. You do know how to start a flooded car, don't you???