• When you click on links to various merchants on this site and make a purchase, this can result in this site earning a commission. Affiliate programs and affiliations include, but are not limited to, the eBay Partner Network.

1968 Charger Hellcat Swapped PWM Cooling Fan set up!

Saleh

Member
Local time
6:46 AM
Joined
Feb 18, 2022
Messages
15
Reaction score
32
Location
Saudi Arabia
Hello everyone,

So this is my first post and I really hope you guys can help me out with my project.

I did a hellcat swap on my 1968 Charger and used the OEM Radiator cooling fan, Also connected PIN #82 to the fan from the ECU but the fan won't work!
Am I missing something here?

Thanks
 
Hello everyone,

So this is my first post and I really hope you guys can help me out with my project.

I did a hellcat swap on my 1968 Charger and used the OEM Radiator cooling fan, Also connected PIN #82 to the fan from the ECU but the fan won't work!
Am I missing something here?

Thanks
You mean to the ground side of a relay correct?
 
The way I see it is that pin #82 energies or operates a relay that switches 12V to operate the fan. The fan also has to be grounded.
 
The way I see it is that pin #82 energies or operates a relay that switches 12V to operate the fan. The fan also has to be grounded.
power and ground are connected to the fan as well as a pcm signal from pin 82
 
power and ground are connected to the fan as well as a pcm signal from pin 82
There has to be a relay involved, even if it is internal to the fan assembly. The PCM signal will not run the fan.
 
Hello everyone,

So this is my first post and I really hope you guys can help me out with my project.

I did a hellcat swap on my 1968 Charger and used the OEM Radiator cooling fan, Also connected PIN #82 to the fan from the ECU but the fan won't work!
Am I missing something here?

Thanks

you updated everything in your tune in HPTuners? Similar to below?

upload_2022-2-19_1-29-23.png
 
This pinout shows PIN 83 is PWM fan control.
upload_2022-2-19_10-40-3.png
 
What about the possibility the fan doesn't work?
 
So you're getting the engine hot and it doesn't fire up? The srts started at like 225* F if I'm not mistaken.
 
I finally figured it out! I moved pin #83 to pin #82 (which was empty in my case) and it finally worked !
I’m about to do the same on my 69 Charger.

Did you end up just using pin #83 to the white wire and power, ground from the fan?
 
Trying to do the same no luck. Had a friend program fan to work but nothing. Used pin 82 for pwm signal and the I just ran a ground and 12v to fan harness no luck. What do I need to do
 
Auto Transport Service
Back
Top