• When you click on links to various merchants on this site and make a purchase, this can result in this site earning a commission. Affiliate programs and affiliations include, but are not limited to, the eBay Partner Network.

How to tell compressor start or run cap

YY1

Well-Known Member
Local time
4:13 PM
Joined
Jun 26, 2010
Messages
26,779
Reaction score
23,235
Location
FL
My shop compressor has been flaking out lately.

I accidentally left it on for a few days, and when I came back, the breaker was tripped.

About every third time it started, it would trip.

I first though it was the unloader valve- stuck maybe, but I removed it and left the tank open, and after about three starts-

It hums but wont start unless I spin the pulley.

If it was hard to spin, I'd suspect the pump, but I'm thinking start cap.

The motor has two caps. How do I know which is which? They are not labeled.

Motor is AO Smith 7 159846 02. Can't find anything on 5 pages of google results.

Thanks.
 
Most motors also have an internal centrifugal switch which can get dirty and hang up if the motor is subject to a lot of dust and dirt in the air.
The switch operates using centrifugal force, so if the switch is dirty, it gets hung up and can't actuate, consequently the motor just sits there and hums.
I have a table saw motor that I have to take apart and clean on a regular basis because it hangs off the back of the saw, and there's a lot of fine dust flying out back there.
 
Heat overload? Mine will get too hot and trip, let it cool down of 30 min and it's good have to turn the on off switch off then back on first as a reset. stuff around yours preventing air cooling?
 
Most motors also have an internal centrifugal switch which can get dirty and hang up if the motor is subject to a lot of dust and dirt in the air.
The switch operates using centrifugal force, so if the switch is dirty, it gets hung up and can't actuate, consequently the motor just sits there and hums.
I have a table saw motor that I have to take apart and clean on a regular basis because it hangs off the back of the saw, and there's a lot of fine dust flying out back there.

My 2 hp Devilbis is doing the same, motor is hanging up in the run winding, tap or move the motor allow the switch to drop into the start winding, could also be the internal switch contacts pitted, worn,etc . Remove the motor to a electric motor
re builder for a freshening up,cheaper than buying a new replacement.
 
Sometimes the Grainger people are reallyhelpful with diagnosis and parts.
 
A lot of multi meters have cap test function
make sure you discharge cap before testing
 
Most motors also have an internal centrifugal switch which can get dirty and hang up if the motor is subject to a lot of dust and dirt in the air.
The switch operates using centrifugal force, so if the switch is dirty, it gets hung up and can't actuate, consequently the motor just sits there and hums.
I have a table saw motor that I have to take apart and clean on a regular basis because it hangs off the back of the saw, and there's a lot of fine dust flying out back there.

X2
 
Do you have a meter that can test microfarads? Symbol should read "μF". If you can compare the value read to the value on the cap it will tell you if it has failed.

You probably will not find anything on that motor as it probably has a model number created for the compressor manufacturer. I can try and cross it for you with my motor winder tomorrow if needed.

- - - Updated - - -

This may help.

http://m.youtube.com/watch?v=OMd9QkinXz4
 
I had a similar problem, but as already mentioned, it turned out to be the centrifical switch. But not the switch itself, it turned out that one of the springs had fallen off, allowing the weights to remain extended as if the motor was already up to speed.

I put the spring back where it belonged and it's run fine ever since.
 
Thanks for the tips guys.

The compressor is a Dewalt/Emglo 55270 that was formerly a gas engine model.

It was professionally converted by a compressor shop with the large 2HP AO Smith motor.

I paid $300 for it and the replacement motor is almost that much.

I'd bet the hourly rate to service is close to $100 as well.

It's been running fine for almost three years until about a month ago.

I found the AO Smith continuous run pool pump motor troubleshooting PDF, but it doesn't show that specific model and doesn't say anything about start vs run cap. It does have the cap testing procedure, though.

Guess I'll test them both starting with the larger capacity one.
 
Auto Transport Service
Back
Top